Panopto System Maintenance - April 12, 2025 @ 9 p.m.

Completed

The scheduled maintenance has been completed.
Posted Apr 13, 2025 - 00:00 CDT

In progress

Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 12, 2025 - 21:00 CDT

Scheduled

Panopto support engineers will be doing an upgrade that requires some downtime. Panopto services will be unavailable on Saturday, April 12, 2025, from 9 p.m. to 11:45 p.m. If you encounter any issues after this maintenance window, we recommend refreshing your web browser and logging in again to Blackboard/Brightspace. For additional assistance, please contact our COLTT Help Desk at: 956-882-6792 (Brownsville) / 956-665-5327 (Edinburg).
Posted Apr 11, 2025 - 13:44 CDT
This scheduled maintenance affected: Panopto.