COLTT Help Desk Portal - Scheduled Maintenance
Completed
The scheduled maintenance has been completed.
Posted Oct 04, 2020 - 03:00 CDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 04, 2020 - 01:01 CDT
Scheduled
On Sunday, October 4th, between 1:00 AM and 3:00 AM CT, Blackboard will be conducting scheduled database maintenance on our help desk portal. If you need Blackboard assistance during this time, please call (956) 882-6792 or (956) 665-5327.
Posted Oct 02, 2020 - 16:11 CDT
This scheduled maintenance affected: COLTT Ticketing System.